
Utiliser Eclipse

Points Clés

• Il semble probable qu’Eclipse puisse être utilisé efficacement avec IBM WebSphere Liberty, Spring,
Spring Boot et Maven, mais la configuration nécessite des configurations spécifiques.

• La recherche suggère d’installer Spring Tool Suite (STS) et IBM Liberty Developer Tools en tant que
plug-ins dans Eclipse pour une fonctionnalité améliorée.

• Les preuves penchent en faveur de la création d’un projet Spring Boot en utilisant STS ou Spring
Initializr, puis de sa configuration pour le déploiement sur WebSphere Liberty.

Configuration d’Eclipse

Pour commencer, téléchargez et installez l’“Eclipse IDE for Enterprise Java and Web Developers”depuis
Eclipse Downloads. Assurez-vous d’avoir JDK 17 ou une version plus récente installée, que vous pouvez
vérifier en exécutant java -version dans votre terminal.

Configuration pour Spring et Spring Boot

Installez le plug-in Spring Tool Suite (STS) en allant dans Help -> Eclipse Marketplace dans Eclipse, en
recherchant “Spring Tools”et en installant la version appropriée. Cela améliore le développement de Spring
et Spring Boot. Vous pouvez créer un nouveau projet Spring Boot directement dans Eclipse via File -> New ->
Spring Starter Project, en sélectionnant Maven comme outil de construction et en ajoutant les dépendances
nécessaires comme Spring Web.

Intégration avec IBM WebSphere Liberty

Installez les IBM Liberty Developer Tools depuis le Eclipse Marketplace en recherchant “IBM Liberty Devel-
oper Tools”et en suivant les invites d’installation. Configurez un serveur WebSphere Liberty en allant dans
Window -> Preferences -> Servers -> Runtime Environments, en ajoutant un nouveau runtime WebSphere
Liberty et en créant une instance de serveur via File -> New -> Other -> Server. Assurez-vous que le fichier
server.xml du serveur inclut la balise <feature>springBoot-2.0</feature> pour le support de Spring Boot,
comme détaillé dans Open Liberty Docs.

Déploiement de Votre Application

Modifiez votre application Spring Boot pour étendre SpringBootServletInitializer au lieu d’utiliser une
méthode principale qui démarre un serveur intégré, en la conditionnant comme un fichier WAR en définis-
sant <packaging>war</packaging> dans votre pom.xml. Déployez en cliquant avec le bouton droit sur le
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projet, en sélectionnant “Run As -> Run on Server”et en choisissant votre serveur Liberty. Cela garantit
que l’application s’exécute sur le conteneur web de Liberty.

Note de l’Enquête : Guide Complet pour Utiliser Eclipse avec IBM WebSphere Liberty, Spring,
Spring Boot et Maven

Ce guide fournit un tutoriel détaillé pour utiliser efficacement Eclipse en conjunction avec IBM WebSphere
Liberty, Spring, Spring Boot et Maven, adapté aux développeurs travaillant dans ces écosystèmes. Le
processus implique la configuration d’Eclipse, l’installation des plug-ins nécessaires, la création et la con-
figuration des projets, ainsi que le déploiement des applications, avec un accent sur l’intégration et les
meilleures pratiques à partir du 27 février 2025.

Configuration d’Eclipse et Prérequis Eclipse sert d’IDE robuste pour le développement Java, en par-
ticulier pour les applications d’entreprise. Pour cette configuration, téléchargez la version “Eclipse IDE for
Enterprise Java and Web Developers”2024-06, disponible à Eclipse Downloads. Assurez-vous que votre sys-
tème dispose de JDK 17 ou d’une version plus récente, que vous pouvez vérifier en exécutant java -version

dans le terminal. Cette version garantit la compatibilité avec les fonctionnalités modernes de Spring et
Liberty.

Installation des Plug-ins Essentiels Pour améliorer Eclipse pour le développement de Spring et Spring
Boot, installez le Spring Tool Suite (STS), la prochaine génération des outils Spring. Accédez à cela via Help
-> Eclipse Marketplace, recherchez “Spring Tools”et installez l’entrée étiquetée “Spring Tools (aka Spring
IDE and Spring Tool Suite).”Ce plug-in, détaillé à Spring Tools, fournit un support de classe mondiale pour
les applications basées sur Spring, s’intégrant sans effort avec Eclipse pour des fonctionnalités comme la
création de projets et le débogage.

Pour l’intégration avec IBM WebSphere Liberty, installez les IBM Liberty Developer Tools, également
disponibles via le Eclipse Marketplace en recherchant “IBM Liberty Developer Tools.”Ce plug-in, testé
pour Eclipse 2024-06 comme mentionné dans IBM Liberty Developer Tools, facilite la construction et le
déploiement des applications Java EE sur Liberty, avec un support pour les versions remontant à 2019-12.

Création d’un Projet Spring Boot Il existe deux méthodes principales pour créer un projet Spring Boot
dans Eclipse avec STS installé :

1. Utilisation de Spring Initializr : Visitez Spring Initializr, sélectionnez Maven comme outil de con-
struction, choisissez vos métadonnées de projet (Group, Artifact, etc.) et ajoutez des dépendances
comme Spring Web. Générez le projet en tant que fichier ZIP, extrayez-le et importez-le dans Eclipse
via File -> Import -> Existing Maven Project, en sélectionnant le dossier extrait.

2

https://www.eclipse.org/downloads/packages/release/2024-06/r/eclipse-ide-enterprise-java-and-web-developers
https://spring.io/tools/
https://marketplace.eclipse.org/content/ibm-liberty-developer-tools
https://start.spring.io/


2. Utilisation de STS Directement : Ouvrez Eclipse, allez dans File -> New -> Other, développez Spring
Boot et sélectionnez “Spring Starter Project.”Suivez l’assistant, en vous assurant que Maven est choisi
comme type, et sélectionnez les dépendances. Cette méthode, décrite dans Creating Spring Boot
Project with Eclipse and Maven, est préférée pour son intégration avec l’espace de travail Eclipse.

Les deux méthodes garantissent un projet basé sur Maven, crucial pour la gestion des dépendances avec
Spring Boot.

Configuration pour le Déploiement sur WebSphere Liberty Pour déployer sur WebSphere Liberty,
modifiez votre application Spring Boot pour s’exécuter sur le conteneur web de Liberty plutôt que de dé-
marrer un serveur intégré. Cela implique :

• De s’assurer que la classe principale de l’application étend SpringBootServletInitializer. Par exemple
:

@SpringBootApplication

public class MyApplication extends SpringBootServletInitializer {

// Pas de méthode principale ; Liberty gère le démarrage

}

• De mettre à jour le pom.xml pour le conditionner en tant que fichier WAR en ajoutant :

<packaging>war</packaging>

Cela est nécessaire pour le déploiement sur un conteneur de servlets traditionnel, comme mentionné
dans Deploying Spring Boot Applications.

WebSphere Liberty, en particulier sa variante open-source Open Liberty, prend en charge les applications
Spring Boot avec des fonctionnalités spécifiques. Assurez-vous que le fichier server.xml du serveur Liberty
inclut la balise <feature>springBoot-2.0</feature> pour le support de Spring Boot 2.x, comme détaillé dans
Open Liberty Docs. Cette configuration désactive le conteneur web intégré, en utilisant celui de Liberty à
la place.

Configuration et Configuration du Serveur WebSphere Liberty dans Eclipse Avec les IBM Liberty
Developer Tools installés, configurez un serveur Liberty :

• Accédez à Window -> Preferences -> Servers -> Runtime Environments, cliquez sur “Add”et sélec-
tionnez “WebSphere Application Server Liberty.”Suivez l’assistant pour localiser votre installation Lib-
erty, généralement dans un répertoire comme <Liberty_Root>/wlp, commementionné dans Liberty and
Eclipse.

• Créez une nouvelle instance de serveur via File -> New -> Other -> Server, en sélectionnant “Web-
Sphere Application Server Liberty”et le runtime que vous avez configuré. Nommez le serveur et ajustez
les paramètres selon les besoins.
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• Éditez le fichier server.xml du serveur, accessible via la vue Servers, pour inclure les fonctionnalités
nécessaires. Pour Spring Boot, ajoutez :

<featureManager>

<feature>springBoot-2.0</feature>

<!-- Autres fonctionnalités comme servlet-3.1 pour le support web -->

</featureManager>

Cette configuration, supportée par IBM WebSphere Liberty, garantit la compatibilité avec les applications
Spring Boot.

Déploiement et Exécution de l’Application Pour déployer, cliquez avec le bouton droit sur votre projet
dans l’Explorateur de Projets, sélectionnez “Run As -> Run on Server,”choisissez votre serveur Liberty
et cliquez sur Finish. Eclipse déploiera le fichier WAR sur le serveur Liberty, et vous pouvez surveiller
les journaux dans la vue Console. Assurez-vous que le contexte de l’application est défini correctement
dans server.xml, généralement sous les balises <webApplication>, pour accéder à votre application via l’URL
appropriée, par exemple, http://localhost:9080/yourapp.

Pour le débogage, utilisez la perspective Debug, en définissant des points d’arrêt selon les besoins, en tirant
parti du support de Liberty pour le débogage à distance, comme discuté dans Debugging with Eclipse and
Liberty.

Considérations Supplémentaires

• Options de Conditionnement : Bien que WAR soit standard pour les conteneurs de servlets, Open
Liberty prend également en charge les déploiements JAR, comme vu dans Configure and Deploy Spring
Boot to Open Liberty. Pour JAR, assurez-vous que l’application est configurée pour ne pas démarrer
un serveur intégré, ce qui peut nécessiter des fonctionnalités ou configurations supplémentaires de
Liberty.

• Intégration Maven : Utilisez Maven pour la gestion des dépendances, en vous assurant que le
liberty-maven-plugin est inclus pour le déploiement automatisé, comme mentionné dans IBM Liberty
Maven Plugin.

• Dépannage : Si des problèmes surviennent, vérifiez les journaux du serveur dans le répertoire logs

sous votre instance de serveur Liberty, et assurez-vous de la compatibilité entre la version de Liberty
et Spring Boot, car des versions comme Liberty 8.5.5.9 ou supérieures prennent en charge les JAR
exécutables, selon Stack Overflow Discussion.

Cette configuration complète garantit une utilisation efficace d’Eclipse pour développer et déployer des
applications Spring Boot sur IBM WebSphere Liberty, en tirant parti de Maven pour la gestion de la con-
struction.

4

https://www.ibm.com/docs/en/was-liberty/base?topic=liberty-overview
https://stackoverflow.com/questions/41428156/how-to-debug-web-service-with-eclipse-websphere-liberty
https://stackoverflow.com/questions/41428156/how-to-debug-web-service-with-eclipse-websphere-liberty
https://openliberty.io/docs/latest/deploy-spring-boot.html
https://openliberty.io/docs/latest/deploy-spring-boot.html
https://github.com/WASdev/ci.maven#liberty-maven-plugin
https://github.com/WASdev/ci.maven#liberty-maven-plugin
https://stackoverflow.com/questions/36132791/how-to-use-websphere-liberty-in-spring-boot-application


Tableau : Comparaison des Options de Déploiement

Type de
Déploiement Avantages Inconvénients Notes de Configuration

Fichier WAR Standard pour les
conteneurs de servlets,
largement supporté

Nécessite l’extension de
SpringBootServletInitializer

Définir
<packaging>war</packaging>

dans pom.xml
Fichier JAR Plus simple pour le

développement, supporté
par Open Liberty

Peut nécessiter des
fonctionnalités
supplémentaires de Liberty

Assurez-vous qu’aucun
serveur intégré ne démarre,
utilisez la fonctionnalité
springBoot

Ce tableau, dérivé de Open Liberty Docs, aide à choisir la stratégie de déploiement appropriée en fonction
des besoins du projet.

Citations Clés

• Creating Spring Boot Project with Eclipse and Maven, guide étape par étape
• IBM Liberty Developer Tools, plugin Eclipse pour les applications Java EE
• Open Liberty Docs, déploiement des applications Spring Boot
• Spring Tools, outils de développement de nouvelle génération pour Spring
• Eclipse Downloads, packages pour le développement Java d’entreprise
• Liberty and Eclipse, installation de l’environnement de développement
• Deploying Spring Boot Applications, référence Spring Boot
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